₤₤ Lex Lawless Website - Browser Requirements

₤₤ Lex Lawless Website - Browser Requirements

The following Web Browser versions and Adobe Plug-ins are recommended for optimal performance:

Windows XP, Vista, 7

Internet Explorer - 8.xWindows Logo
Mozilla Firefox - 3.5.5
Google Chrome - 3.0.x
Safari - 4.0.4
Opera - 10.x


Mac OS X
Apple Logo
Safari - 4.0.4      
Mozilla Firefox - 3.5.5 
Opera - 10.x



Adobe ApplicationsAdobe Logo
The latest versions of these Adobe Applications must be installed in your browser:


Adobe Flash Player - v10.0.x

Get Adobe Flash Player



Adobe Shockwave Player
- v11.5.x

Get Adobe Shockwave Player